RS246.com Forum :: The World’s #1 Audi R, S and RS Enthusiast Community

Air con fault

Air con fault

Post by Human Joist » Sun Jun 23, 2019 9:34 am

Quick question on the air con if you please

It’s not working

I have run a fault code with nothing coming up. The economy light goes out when pressed but I can’t hear the compressor kick in. It was full of gas but I have had the gas changed just Incase.

I’m thinking it may be the compressor clutch assembly but just wondering if there is anything else to check first

And secondly is there a guide for swapping it over as I can’t find one on here

Thanks In advance

Re: Air con fault

Post by Ajc » Sun Jun 23, 2019 9:54 am

04 c5 rs6 , Ebony Black, Bare shell repaint , Milltek’s, PSS9’s,Hotchkis Arb’s,Gutted precats, hybrid turbos, Bosch 044 ,And an annoying EML light

Re: Air con fault

Post by Shoppinit » Sun Jun 23, 2019 11:07 am

Re: Air con fault

Post by Human Joist » Sun Jun 23, 2019 5:52 pm

Ok. How would I check the elegant bits then ?

I did get the high pressure switch suggestion from a friend but would that not give a fault code. Is there a way to check it and where is it located ?

Cheers for the help by the way

Re: Air con fault

Post by Classik » Sun Jun 23, 2019 10:35 pm

Re: Air con fault

Post by Shoppinit » Mon Jun 24, 2019 1:02 am

^What he said. There’s a link to some info on changing it in the FAQ.

Check the HVAC with the Vagcom to see why the AC isn’t being activated.

If it’s not the switch, it could be the compressor. You should check that the activation signal is getting to the compressor. I fixed an AC problem in the Saab that was due to a knackered compressor relay. The hvac was asking for the compressor, but the relay contacts were shot and 12V wasn’t getting to the compressor. I could force the compressor to start by bringing 12V to it so I new it wasn’t a mechanical problem. /just seen that this is what ajc is suggesting also.

I’m not in a position to look at the wiring diagrams at the mo, so I can’t tell you if it’s the same system on the RS6.

Re: Air con fault

Post by Human Joist » Tue Jul 02, 2019 8:28 pm

Ok. So checking this on VCDS. It was block 2 for reasons it’s not working etc. The current value was working from 0 compressor on. Then changing to 6 when I turned it off.

The last three reasons were all 0 so not giving any reasons for it being turned off. Had the car running testing as well. It all stayed the same. I can turn the econ button on and off and it allows me too.

Is there a way to test the high pressure switch before replacing it ?

Re: Air con fault

Post by Human Joist » Thu Jul 04, 2019 12:23 pm

Adblock
detector