Uh, HELP! Electronic immobilizer needs resetting?

[searched the forum but didn’t find anything about resetting the immobilizer]

Here’s the situation:

1. Drove the AR last night no problem.
2. Gave wife ‘extra’ key this AM so she could use the car
3. She gets in, uses the extra key, and the AR turns over but then stalls out.
4. She’s stuck and reverts back to the ’89 Legend. Thank god I had a backup car for her!
5. I come home, read about the immobilizer and say ‘that’s what happened’.
6. Thinking my key must still work (it worked last night) — I use my key to try to start the AR — but no luck, same thing regardless of which key we use.

THE PROBLEM — the user manual doesn’t say how to reset this thing!? I’m 99.99% sure that the thing was tripped when my wife used the extra key, but I don’t see how to reset it!?

He confirmed I’d likely have to have it towed. He said try all the keys — including valet — and we did and still no go. Dealer says he’ll have to reprogram the keys.

The good news — the dealer is open on Saturday and I have free AAA towing! So I’m not without all weekend..but, what does it cost to have the keys reprogrammed? Is THAT the bad news?

The bits of reading I did on the immobilizer are that:

. the car knows about the keys it should trust, by being ‘introduced’ to all of them in a single procedure
. attempting to start the car using an unauthenticated key can result in the car revoking authentication for all trusted keys
. the dealer needs to get (from audi) a s00per sekrit, time-limited code, to allow the introduction process to take place again

the «authorized» key will still work after trying an «un-authorized» one. All the immobilizer is doing is looking for a match, finds one. car starts. No match, no start.

In fact the ignition lock cylinder on the new A8’s is not even keyed. You can put any switchblade key into it and turn it, but since they are not matched to the car, the electric column lock will not release and the car will not start. Put the correct key in all is well.

It is possible the ignition switch may be bad in GottaAllroads car since both keys are inop.

When the wrong key is used you get 1/2 second of engine life then nothing.Light that shows a KEY and a Car in the cluster when the immob. is activated. Is this showing up?

Are you getting the engine light instead? IMO there is something else and not the immob. that is wrong. A VAG COM Scan may show a lot for you. It may just be a simple wire somewhere.

w/engine cutoff as you described after 1/2 second of run time. No other engine light. should have mentioned this in the original post.

Anyway, towed it to dealer today. They checked it and did a $130 reprogramming of the key set, and all is well now.

My guess: the original ‘extra’ key had never been programmed, misprogrammed (by prior owner?), or whatever. I think this is what triggered when the wife put in the extra key, and once that was done no other key (in particular, the one I had been using for 6 months since I bought the AR) worked.

That seems a bit harsh since if it happens and you’re not near a dealer you are 100% screwed. I’m glad it happened at home, or else it’d been even more of a drag.

Still LOVE the AR, so I don’t care about these inconveniences and/or ghosts in the machine. now I can drive it to my friends and get those H-Sports put on next week. and then hit the road to the coast and have a lot more fun along the way.

Adblock
detector