How to clean BMW X5 air conditioning ?

2 Years into my ownership of my X5, and the A/C has a musky smell.

When I brought it in for service, I told them about it, and the dealer said they cleaned the A/C system. Few months later the smell came back. I complained about it at the next service and the dealer said they initially cleaned it as a courtesy and that they could not clean it again. I told them that I didn’t want them to just clean it but to fix the issue. They said its not covered as part of the warranty nor the BMW service. I also have the extended warranty and extended service plan.

The smell only occurs during the first minute of the A/C system being turned on. Its also more pronounced when the A/C compressor is off. Otherwise when its on, other than the first minute, it smells fine.

I live in San Diego, so the weather is generally great. No winter and no humidity to really impact the A/C system.

Any recommendations on what I should do next?

The musty/musky smell usually comes from the growth of bacteria & mold due to perfect conditions that allow for them to grow. You probably need to find a way to PREVENT this growth. especially if you park your car in a garage or in a location that has limited air circulation and darkness.

If the dealership cleaned your AC system and killed off the bacteria and mold prior. and the smell abated at that time. but has now returned. the issue is to CHANGE the situation that allows bacteria and mold to grow.

Personally, I haven’t had this condition for the last 30 years because I follow certain steps. Anytime I’ve been running the AC (especially in hot temps). if I’m parking in a DARK location with limited air circulation (like pulling into my garage and parking for the night). I run the park ventilation feature.

Using the park ventilation feature will run the HVAC blower for up to 30 minutes (without the key in the ignition) which helps evaporate any remaining condensate on the AC condenser. This helps prevent the growth of bacteria and mold.

If the ambient temps aren’t extremely hot (like 85°F-105°F). and it is comfortable enough. I will turn off the AC a few miles before my destination. which will do the same. and help dry off any condensate. again, helping to eliminate the birthing ground for bacteria and mold.

There is lots of info out on the internet on how to kill the growth of bacteria and mold from a car’s AC system. once you’ve killed the bacteria & mold. try circumventing the conditions that causes it to return. and see if it eliminates the funky smell from your AC system.

11-10-2018, 01:33 PM #2
11-10-2018, 01:51 PM #3

11-10-2018, 01:56 PM #4

As mentioned in my post above. to help prevent the growth of bacteria/mold that causes the funky smell upon start up of the HVAC blower. activate the park ventilation feature (see pic below) especially if parking in your garage where it will be dark and no air circulation to dry the condenser.

The immediate venting feature can only be started when the engine is OFF. so find this feature under CLIMATE. To activate the «immediate parked vent feature» (seen highlighted in pic below) STOP the engine from running but still have the car’s electronics on. then make the selection. If the engine is running, the selection will be «grayed-out» like in pic below and you won’t be able to activate it:

11-10-2018, 02:23 PM #5

The musty/musky smell usually comes from the growth of bacteria & mold due to perfect conditions that allow for them to grow. You probably need to find a way to PREVENT this growth. especially if you park your car in a garage or in a location that has limited air circulation and darkness.

If the dealership cleaned your AC system and killed off the bacteria and mold prior. and the smell abated at that time. but has now returned. the issue is to CHANGE the situation that allows bacteria and mold to grow.

Personally, I haven’t had this condition for the last 30 years because I follow certain steps. Anytime I’ve been running the AC (especially in hot temps). if I’m parking in a DARK location with limited air circulation (like pulling into my garage and parking for the night). I run the park ventilation feature.

Using the park ventilation feature will run the HVAC blower for up to 30 minutes (without the key in the ignition) which helps evaporate any remaining condensate on the AC condenser. This helps prevent the growth of bacteria and mold.

If the ambient temps aren’t extremely hot (like 85°F-105°F). and it is comfortable enough. I will turn off the AC a few miles before my destination. which will do the same. and help dry off any condensate. again, helping to eliminate the birthing ground for bacteria and mold.

There is lots of info out on the internet on how to kill the growth of bacteria and mold from a car’s AC system. once you’ve killed the bacteria & mold. try circumventing the conditions that causes it to return. and see if it eliminates the funky smell from your AC system.

Thanks Qsilver7. I am going to have a hard time explaining this to my wife, and in reality, she will never drill down the menu to activate it, or remember to turn off A/C a few miles before arrival.

I wouldn’t even blame her as this is unacceptable for a $70k car.

I just ordered some Kilma Cleaner that I will spray through evaporator temp sensor, will keep everyone posted on the results.

11-10-2018, 02:49 PM #6

As mentioned in my post above. to help prevent the growth of bacteria/mold that causes the funky smell upon start up of the HVAC blower. activate the park ventilation feature (see pic below) especially if parking in your garage where it will be dark and no air circulation to dry the condenser.

The immediate venting feature can only be started when the engine is OFF. so find this feature under CLIMATE. To activate the «immediate parked vent feature» (seen highlighted in pic below) STOP the engine from running but still have the car’s electronics on. then make the selection. If the engine is running, the selection will be «grayed-out» like in pic below and you won’t be able to activate it:

That’s a very good idea.

What I usually do is after using the AC for a length of time, will turn off and just run on the vent (non-AC) for a period before arriving at my destination.

11-11-2018, 05:14 AM #7
The Libertine
View Public Profile
Find More Posts by The Libertine

That’s a very good idea.

What I usually do is after using the AC for a length of time, will turn off and just run on the vent (non-AC) for a period before arriving at my destination.

I do that, too. but on those hot summer days when it would be stifling to turn off the AC before pulling into the garage (like when temps are like 85° F-up and 100% humidity). that’s when I use the park ventilation feature. or if I forgot to turn off the AC before getting too close to home or my destination.

Thanks Qsilver7. I am going to have a hard time explaining this to my wife, and in reality, she will never drill down the menu to activate it, or remember to turn off A/C a few miles before arrival.

I wouldn’t even blame her as this is unacceptable for a $70k car.

I just ordered some Kilma Cleaner that I will spray through evaporator temp sensor, will keep everyone posted on the results.

The issue is not that its a $70K car. it happens to ALL cars. It’s a naturally occuring conditions based on «conditions» that have nothing to do with the cost/price of the vehicle. the bacteria & mold grow due to dampness, heat, and darkness. Just like if you had a $1 towel purchased at The Dollar Store or a $100 Egyptian cotton towel purchased from a high dollar department store. if you were to use either after a extreme workout and shower. then throw it (still wet) into your gym bag and zip it up, then toss the bag into your trunk on a 90°F summer day. both towels will stink to high heaven when you open the bag the next day.

Even after using the Kilma Cleaner to kill the bacteria & mold. if the conditions that allow the growth are still present. then it will return and you’ll need to use the Kilma Cleaner over and over again when the issue returns.

Changing the environment or conditions that cause the growth is what will stop the issue.

I just thought of something in regards to helping your wife. perhaps you can make it simple & easier by creating a preset where all she needs to do is press ONE button and the activation screen appears.

The 1-8 preset buttons below the CD/DVD slot is not just for radio presets. They can be used to bring up something specific for anything the CIC/NBT/NAV/etc can do. If you put your finger up to the 1st button. you should see anything you’ve set appear. and if you move your finger across all the buttons. the display will show what all has been set on each button.

For instance, I set one of the buttons to have the NAV destination for home. so in case I’m somewhere unfamiliar. like from following friends to a location or just plain lost. I can just press the one preset button and it wil automatically set the navigation to direct me back home. I also did one for bringing up ALL of my radio presets. I bet you can do a preset to bring up the park ventilation screen. which I will probably do now that I’ve brought it up (thanks ).

11-11-2018, 05:48 AM #8

I do that, too. but on those hot summer days when it would be stifling to turn off the AC before pulling into the garage (like when temps are like 85° F-up and 100% humidity). that’s when I use the park ventilation feature. or if I forgot to turn off the AC before getting too close to home or my destination.

The issue is not that its a $70K car. it happens to ALL cars. It’s a naturally occuring conditions based on «conditions» that have nothing to do with the cost/price of the vehicle. the bacteria & mold grow due to dampness, heat, and darkness. Just like if you had a $1 towel purchased at The Dollar Store or a $100 Egyptian cotton towel purchased from a high dollar department store. if you were to use either after a extreme workout and shower. then throw it (still wet) into your gym bag and zip it up, then toss the bag into your trunk on a 90°F summer day. both towels will stink to high heaven when you open the bag the next day.

Even after using the Kilma Cleaner to kill the bacteria & mold. if the conditions that allow the growth are still present. then it will return and you’ll need to use the Kilma Cleaner over and over again when the issue returns.

Changing the environment or conditions that cause the growth is what will stop the issue.

I just thought of something in regards to helping your wife. perhaps you can make it simple & easier by creating a preset where all she needs to do is press ONE button and the activation screen appears.

The 1-8 preset buttons below the CD/DVD slot is not just for radio presets. They can be used to bring up something specific for anything the CIC/NBT/NAV/etc can do. If you put your finger up to the 1st button. you should see anything you’ve set appear. and if you move your finger across all the buttons. the display will show what all has been set on each button.

For instance, I set one of the buttons to have the NAV destination for home. so in case I’m somewhere unfamiliar. like from following friends to a location or just plain lost. I can just press the one preset button and it wil automatically set the navigation to direct me back home. I also did one for bringing up ALL of my radio presets. I bet you can do a preset to bring up the park ventilation screen. which I will probably do now that I’ve brought it up (thanks ).

The preset is a good idea. But she still won’t use it.

I’ve owned 6 cars before, this is the first to do this (I do realize this is not statically significant). So while I somewhat agree its about conditions, its also about engineering with regards to how the car vents the evaporator to allow it to dry. My in-laws XC90 has a fan that stays on for

10min after car stops to do just that.

I used the Kilma Cleaner yesterday. It was pretty easy to use:

For anyone wondering, it toke 30mins in all with 20mins of that is waiting:
1. Removed the side driver side carpet (1 torx screw, move seat all way back)
2. Removed the Evaporator temp sensor by just pulling it out.
3. Kilma Cleaner comes with a long snake tube, I put it on and sprayed the evaporator. Dragging the long tube back and forth to make sure the evaporator is fully covered the the Kilma foam.
4. Wait 20min.
5. Put everything back together.
6. Put A/C full blast with outside air open for 5min. (not max a/c since that turns on reciculration on)

Smell seems to have gone away. Will see if it holds up for the next few weeks.

I plan on doing this again in 3-4 months then every service cycle.

Adblock
detector
11-11-2018, 03:54 PM #9