2021 SL GPS not working

joles1970

Registered

Cryogenix1

Registered

Since I don’t use the NAV system to get around, I couldn’t say if the GPS on my 2021 SL was working correctly when I bought it last April. I know after about 5-6 months I was looking at the NAV map and my location was correct. I seemed to have accidentally solved a couple of strange electrical glitches after disconnecting the battery for a loose fuel cap issue. 2-3 weeks after doing that, the sideview mirror anti-tilt feature started working when centering the button.

In any case, you might try disconnecting the NEG battlery cable for a minute, then reconnecting it. If you do that, be sure before reconnecting it that everything in the car is off and that all doors are closed, otherwise you might get a spark show when reconnecting the cable.

The only easier solution I could suggest trying is pushing in and holding the scroll and volume knobs at the same time for about ten seconds. That will reboot/reset the head unit and might clear some cobwebs out of the system.

If I remember correctly, when I did look at the NAV map and my location, it offered the choice to adjust the coordinates of my location if the GPS reading wasn’t correct. You might try making an adjustment to suit your location — even if it’s only a minor change. Maybe that will set things straight.

maximumsport

Registered

Since I don’t use the NAV system to get around, I couldn’t say if the GPS on my 2021 SL was working correctly when I bought it last April. I know after about 5-6 months I was looking at the NAV map and my location was correct. I seemed to have accidentally solved a couple of strange electrical glitches after disconnecting the battery for a loose fuel cap issue. 2-3 weeks after doing that, the sideview mirror anti-tilt feature started working when centering the button.

In any case, you might try disconnecting the NEG battlery cable for a minute, then reconnecting it. If you do that, be sure before reconnecting it that everything in the car is off and that all doors are closed, otherwise you might get a spark show when reconnecting the cable.

The only easier solution I could suggest trying is pushing in and holding the scroll and volume knobs at the same time for about ten seconds. That will reboot/reset the head unit and might clear some cobwebs out of the system.

If I remember correctly, when I did look at the NAV map and my location, it offered the choice to adjust the coordinates of my location if the GPS reading wasn’t correct. You might try making an adjustment to suit your location — even if it’s only a minor change. Maybe that will set things straight.

Just read your post. You said the auto tilt feature works when the slider is in the middle? I thought putting the slider in the middle disables it? If I move mine to engage the left or right mirror then only does it work when put in Reverse of course.

Just making sure mine is working correctly.

Adblock
detector